Sorry ): Altough this is an archaic game, we still require a modern browsers. Try Chrome, Firefox, Safari or any other browser that supports HTML5.